[CI] add installation of requirements.txt

4 jobs for add_unitsystem in 4 minutes and 44 seconds
Status Job ID Name Coverage
  Test
failed #93716
test:python3.5-stretch-pyqt5_larch

00:01:59

failed #93715
test:python3.5-stretch-pyqt5_pymca

00:04:44

failed #93717
test:python3.5-stretch-pyqt5_pymca_larch

00:03:59

failed #93718
test:test-est-tutorials_pymca

00:03:05

 
Name Stage Failure
failed
test:python3.5-stretch-pyqt5_pymca Test
Successfully built PyMca5 fisx
Installing collected packages: fisx, PyMca5, PyOpenGL, pymca
Successfully installed PyMca5-5.5.4 PyOpenGL-3.1.5 fisx-1.1.8 pymca-5.5.4
$ python -m pip install requirements.txt
ERROR: Could not find a version that satisfies the requirement requirements.txt (from versions: none)
ERROR: No matching distribution found for requirements.txt
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1
failed
test:python3.5-stretch-pyqt5_pymca_larch Test
Successfully built PyMca5 fisx
Installing collected packages: PyOpenGL, fisx, PyMca5, pymca
Successfully installed PyMca5-5.5.4 PyOpenGL-3.1.5 fisx-1.1.8 pymca-5.5.4
$ python -m pip install requirements.txt
ERROR: Could not find a version that satisfies the requirement requirements.txt (from versions: none)
ERROR: No matching distribution found for requirements.txt
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1
failed
test:test-est-tutorials_pymca Test
     63 
64 __all__ = ["ur", "units"]

ImportError: No module named 'pint'
ImportError: No module named 'pint'

Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1
failed
test:python3.5-stretch-pyqt5_larch Test
Requirement already satisfied, skipping upgrade: setuptools in /usr/local/lib/python3.7/site-packages (from silx) (46.1.3)
Installing collected packages: h5py, silx
Successfully installed h5py-2.10.0 silx-0.13.0b0
$ python -m pip install requirements.txt
ERROR: Could not find a version that satisfies the requirement requirements.txt (from versions: none)
ERROR: No matching distribution found for requirements.txt
Running after_script
Uploading artifacts for failed job
ERROR: Job failed: exit code 1