GitLab will be upgraded on June 23rd evening. During the upgrade the service will be unavailable, sorry for the inconvenience.

[hdf5][tomoscan] return intrument/detector/tomo_n instead of len(projections)

4 jobs for add_tomo_n in 7 minutes and 18 seconds (queued for 1 second)
latest
Status Job ID Name Coverage
  Style
passed #207534
check_style

00:00:13

 
  Test Library
failed #207535
test:python3.7_stretch_pyqt5

00:07:04

79.0%
failed #207536
test:python3.9_stretch_pyqt5

00:05:26

 
  Test Notbooks
skipped #207537
test:test-tomoscan-tutorials
 
Name Stage Failure
failed
test:python3.7_stretch_pyqt5 Test Library

=========================== short test summary info ============================
FAILED tomoscan/esrf/test/test_hdf5scan.py::TestHDF5Scan::testAxisUtils - Ass...
FAILED tomoscan/esrf/test/test_hdf5scan.py::TestHDF5Scan::testDarkRefUtils - ...
FAILED tomoscan/esrf/test/test_hdf5scan.py::TestGetSinogram::testGetSinogram5
FAILED tomoscan/esrf/test/test_hdf5scan.py::TestGetSinogramLegacy::testImplementations
============= 4 failed, 49 passed, 1 warning in 143.20s (0:02:23) ==============
Cleaning up file based variables
ERROR: Job failed: exit code 1
failed
test:python3.9_stretch_pyqt5 Test Library
INTERNALERROR>   File "/usr/lib/python3/dist-packages/pytestqt/qt_compat.py", line 83, in set_qt_api
INTERNALERROR> raise RuntimeError(msg)
INTERNALERROR> RuntimeError: pytest-qt requires either PySide, PySide2, PyQt4 or PyQt5 to be installed
INTERNALERROR> PyQt4.QtCore: No module named 'PyQt4'
INTERNALERROR> PyQt5.QtCore: No module named 'PyQt5.QtCore'
INTERNALERROR> PySide.QtCore: No module named 'PySide'
INTERNALERROR> PySide2.QtCore: No module named 'PySide2'
Cleaning up file based variables
ERROR: Job failed: exit code 1