Commit d0965139 authored by payno's avatar payno
Browse files

install silx from master

parent 8a78d324
Pipeline #36655 passed with stages
in 11 minutes and 13 seconds
......@@ -19,7 +19,6 @@ check_style:
before_script:
- pip install black
script:
- pip install -r requirements.txt
# run black
- LC_ALL=C.UTF-8 black --check --safe .
......@@ -34,12 +33,14 @@ doc:
- arch
- which python
- python --version
- source ./ci/install_scripts.sh
- python -m pip install pip --upgrade
- python -m pip install setuptools --upgrade
- python -m pip install sphinx
- python -m pip install nbsphinx
- python -m pip install nbconvert
- python -m pip install pandoc
- install_silx
- python -m pip install -r requirements.txt
- rm -rf artifacts
- mkdir artifacts
......@@ -66,8 +67,10 @@ doc:
- export LD_LIBRARY_PATH=/lib/x86_64-linux-gnu/:${LD_LIBRARY_PATH}
- export ORANGE_WEB_LOG='False'
- python --version
- source ./ci/install_scripts.sh
- python -m pip install pip --upgrade
- python -m pip install setuptools --upgrade
- install_silx
- python -m pip install -r requirements.txt
- python -m pip install .
script:
......@@ -95,6 +98,7 @@ test:test-tomoscan-tutorials:
- export LD_LIBRARY_PATH=/lib/x86_64-linux-gnu/:${LD_LIBRARY_PATH}
- export ORANGE_WEB_LOG='False'
- python --version
- source ./ci/install_scripts.sh
- python -m pip install pip --upgrade
- python -m pip install setuptools --upgrade
- python -m pip install numpy --upgrade
......@@ -103,6 +107,7 @@ test:test-tomoscan-tutorials:
- python -m pip install nbconvert
- python -m pip install pandoc
- python -m pip install ipykernel
- install_silx
- python -m pip install -r requirements.txt
- python -m pip install fabio --upgrade --pre
- python -m pip install silx --upgrade --pre
......
#!/bin/bash
function install_silx(){
if [ "$2" = 'latest' ]; then
python -m install silx
else
python -m pip install git+https://github.com/silx-kit/silx.git
fi
}
function silx_version(){
python -c 'import silx; print(silx.version)'
}
silx>=0.14
# silx>=0.14
lxml
numpy
\ No newline at end of file
......@@ -321,7 +321,7 @@ def get_project_configuration(dry_run):
install_requires = [
# for the script launcher and pkg_resources
"setuptools",
"silx>=0.14",
"silx>=0.14a",
"lxml",
]
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment