Commit bea40917 authored by Pierre Paleo's avatar Pierre Paleo
Browse files

cli: nabu-config: remove --bootstrap flag

parent 7f4e416f
......@@ -23,9 +23,11 @@ def bootstrap():
do_convert = (args["convert"] != "")
no_comments = bool(args["nocomments"])
if (do_bootstrap ^ do_convert) == 0:
print("You must specify either --bootstrap or --convert")
exit(0)
if do_convert: # do_convert
print("The --convert option is deprecated. It will be removed in a future version")
exit(1)
if do_bootstrap:
print("The --bootstrap option is now the default behavior of the nabu-config command. This option is therefore not needed anymore.")
if path.isfile(args["output"]):
rep = input("File %s already exists. Overwrite ? [y/N]" % args["output"])
......@@ -33,18 +35,14 @@ def bootstrap():
print("Stopping")
exit(0)
if do_bootstrap:
prefilled_values = {}
if args["dataset"] != "":
prefilled_values["dataset"] = {}
prefilled_values["dataset"]["location"] = args["dataset"]
generate_nabu_configfile(
args["output"],
comments=not(no_comments),
options_level=args["level"],
prefilled_values=prefilled_values,
)
else: # do_convert
print("PyHST file converter is not implemented yet")
exit(1)
prefilled_values = {}
if args["dataset"] != "":
prefilled_values["dataset"] = {}
prefilled_values["dataset"]["location"] = args["dataset"]
generate_nabu_configfile(
args["output"],
comments=not(no_comments),
options_level=args["level"],
prefilled_values=prefilled_values,
)
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment