Commit 99b797d6 authored by Thomas Vincent's avatar Thomas Vincent

Add cython to required build packages

parent cbafc886
......@@ -716,16 +716,16 @@ def get_project_configuration(dry_run):
numpy_requested_version = ""
else:
from numpy.version import version as numpy_version
numpy_requested_version = " >= %s" % numpy_version
numpy_requested_version = ">=%s" % numpy_version
logger.info("Install requires: numpy %s", numpy_requested_version)
install_requires = [
# for most of the computation
"numpy %s" % numpy_requested_version,
"numpy%s" % numpy_requested_version,
# for the script launcher
"setuptools"]
setup_requires = ["setuptools", "numpy"]
setup_requires = ["setuptools", "numpy", "Cython>=0.21.1"]
package_data = {
'xsocs.resources': [
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment