Commit 4da23337 authored by Thomas Vincent's avatar Thomas Vincent

Add requirements files for project dependencies

parent 27b69f4a
# List of xsocs development dependencies
# Those ARE NOT required for installation or at runtime
numpy >= 1.8
setuptools # Advanced packaging tools
wheel # To build wheels
Cython >= 0.21.1 # To regenerate .c/.cpp files from .pyx
Sphinx # To build the documentation in doc/
lxml # For test coverage in run_test.py
coverage # For test coverage in run_test.py
pillow # For loading images in documentation generation
nbsphinx # For converting ipynb in documentation
\ No newline at end of file
# List all dependencies of xsocs
# Requires pip >= 8.0
--trusted-host www.silx.org
--find-links http://www.silx.org/pub/wheelhouse/
--only-binary numpy,h5py,scipy,PyQt5
xrayutilities
# Following minimal versions are those available in Debian 8
numpy >= 1.8.2
scipy >= 0.14.0
h5py >= 2.6.0
silx >= 0.7.0
matplotlib >= 1.4.2
PyOpenGL >= 3.0.2
PyQt5 >= 5.3.2
\ No newline at end of file
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment