requirements-dev.txt 689 Bytes
Newer Older
1 2 3 4
# List of xsocs development dependencies
# Those ARE NOT required for installation or at runtime

numpy >= 1.8
5 6 7 8 9 10 11 12 13
setuptools                   # Advanced packaging tools
wheel                        # To build wheels
Cython >= 0.21.1             # To regenerate .c/.cpp files from .pyx
Sphinx                       # To build the documentation in doc/
lxml                         # For test coverage in run_test.py
coverage                     # For test coverage in run_test.py
pillow                       # For loading images in documentation generation
nbsphinx                     # For converting ipynb in documentation
sphinxcontrib.programoutput  # To generate doc from command line